NSWindows not closing the second time...


I have tried to migrate one of my ASOC projects from Xcode 3.2 on snow leopard to Xcode 4.1 on lion (on a separate partition of course!) for the first time. I chose a simple project to gain experience with the new Xcode, and i’ve hit a problem that I haven’t been able to solve in many days.

I have 3 NSWindows in my XIB, the main one is fine, but the other two behave in a manner that wasn’t there before in Snow Leopard. If I open one of them and close it, it’s all fine, but if I open it again, I can’t close it, the app is half-stuck (the windows are not responding but I can do Cmd-Q just fine), and the title bar buttons (red, yellow and green) are in the clicked state already when they open, even though I am not clicking them.

I have tried all sorts of combination in settings in the “interface builder” part of Xcode to no result. Here are my current settings

I’m testing things on only one of them, and it’s a standard NSWndow, nothing fancy. And i’ve set it

My goal is for this app to work both under Snow Leopard and Lion. I’m afraid that whatever changes I will do in Lion to fix this problem will make it stop working in SL. I don’t mind having to keep working in Lion and Xcode 4.1 as long as it works on 10.6 and 10.7.

Anyone has a clue? Thank you in advance…

Anyone had this problem before?

Browser: Safari 534.48.3
Operating System: Mac OS X (10.7)

I’m not sure if I follow your description, but try turning off Release When Closed and One Shot.

Yeah, turns out that was the solution. Thank you!

I hope it still works fine under 10.6… gonna try it soon.

Browser: Safari 534.48.3
Operating System: Mac OS X (10.7)