Odd behavior of NSTextField

When I start my program the first textfield is highlighted. If I start typing the cursor moves but I can’t see any text.

If I press tab first and then start typing its fine.
I’ve tried it on a couple different Snow Leopard systems and it does the same thing.

I tried to set focus to the NSTextField when the program launches but that didn’t make any difference

Any thoughts?

Have you set a delegate for the field? What attribute settings have you made for it?

I have a delegate:

property show_abbreviation : missing value

I haven’t set any attributes

That’s not a delegate – I assume you mean that’s the outlet you’ve connected to in Interface Builder.

You’re not giving us a lot of clues. Is it a case of you just added a text field to a new project and it happened, or is there other stuff going on in the app?

Sorry I’m getting my terms all mixed up.

I have just removed all the code from the program and justed launch the interface and it does the same thing

I built a new project with a couple of NSTextFields and it works normally.
Hmm. Could my IB project be corrupt?

it can happen, yes.

OK I rebuilt the interface from scratch, pasted my code and everything is fine now.

Thank you very much for your help and I apologize for not explaining things clearly.