on mouseEntered question

I’ve been using a set up like the below in my app built in Xcode 4.0.1 running under Mac OSX 10.6.8 with no issues, the problem now is that when running the app under OSX 10.7.1 the code has stopped working, no pointing hand cursor and no window coming to the front, any ideas why it would have stopped working would be apreciated

   property custView1_1 : missing value -- connected in ib
   property WD102_1_info : missing value -- connected in ib
   property trackingArea1_1 : missing value 
   property NUMBER_1 : missing value
		 on mouseEntered_(theEvent)
        if theEvent's trackingArea() is trackingArea1_1 then
            current application's NSCursor's pointingHandCursor()'s |set|()
            set _MachInfo to "test"
            NUMBER_1's setStringValue_(_MachInfo) 
            WD102_1_info's orderFront_(me)
			 end if
    end mouseEntered_
	on mouseExited_(theEvent)
        current application's NSCursor's closedHandCursor()'s |set|()
        WD102_1_info's orderOut_(me)
           end mouseExited_

   on awakeFromNib()
        set trackingArea1_1 to current application's NSTrackingArea's alloc()'s initWithRect_options_owner_userInfo_(missing value, 545, me, missing value)
        custView1_1's addTrackingArea_(trackingArea1_1)
		end awakeFromNib 

I don’t know if this applies, since I am using Xcode 3.2.6, but I am running under Lion. It didn’t work for me either with your code, but changing the “missing value” argument in the init method to custView1_1’s frame() worked for me.

initWithRect_options_owner_userInfo_(custView1_1’s frame(), 545, me, missing value)


gidday Ric

worked like a charm, thanks very much for checking this out for me.