[os9.2.2]Mount w2k share problems


I’m damaging my brains with this one.

I’ve created an applescript on os 10.2.6 wich looks like this:

tell application "finder"
mount volume "afp://" as user name "apple" with password "apple"
end tell

This works great on 10.2.6, but when I run the exact same script (copied from a text file to the 9.2.2 editor) on 9.2.2 it gives the error: -1070

I’ve searched here, and found similar people experiencing the same problems.

What’s wrong? Am I missing something over here?

OS 10.2.6 is running Applescript 1.9.1
OS 9.2.2 is running Applescript 1.8.3

A minor update on this issue:

when I use the following script:

tell application "finder"
mount volume "afp://"
end tell

It works great, only I must type the username and password manually.

So it seems the problem is with the passwords being sent in clear text. (found some hints to that on google).

But still no progress on this issue.

And yet again an update:

I found that the mount command should work like this:

mount volume "sharepoint" on server "servername" as user name "username" with password "password"

This works on 1 server. The other server (the live environment) still gives an error.
I tried to replace servername with an IPadres. Still an error.
So it looks like the problem is on the server.

It’s a dual processort server. Found on the windows KBase it states that a multiprocessor sometimes errors in giving it’s name in the chooser. This should be fixed in Windows 2000 SP4. This is also installed.

Anyway, the problem is:

the mount volume afp://user:pass@xxx.xxx.xxx.xxx/sharepoint still doesn’t work on os 9.2.2. It works great in 10.2.6

I’m going mad overhere!!!

I was getting the -1070 and -3170 errors trying to mount a volume on another Mac. I finally found a script at


and that did the trick.