OSX 10.4 will not start - can you help?

Machine: iMac aluminum
OS: OSX 10.4
Problem: powers up, will not complete start up sequence
What led to the problem: Ignorance, mostly. CD was stuck in vertical bay and I tried someone’s suggestion to eject via terminal. If you are laughing (and/or groaning), you know what must have happened.

Solutions attempted: applejack, fsck -fy … multiple times.
Results: disk & permissions repaired and/or verified but OSX still will not start up. It starts with grey screen, goes to blue with grey window. Progress bar moves slowly from left to right and seems to reach 100%. Operation stalls at that point.

Note: Any attempt to use diskutil stalls and commands such as list, mount do not execute. Command S will get me to root … where can I go from there?


actually this is an AppleScript forum :wink:

Three suggestions

  1. Hold the left mouse button during startup. This normally ejects the disk

  2. Boot in single user mode (⌘S), type mount -uw / ↩ then drutil eject ↩

  3. Boot in safe mode, that means hold the Shift key down until the blue screen appears
    with a message like “extensions disabled” or something like this

Thank you for your assistance, Stefan. I did not know where else to turn…my first panicked thought was the experts here, not realizing emergency repair was not the forum’s focus.

I tried your suggestions; disk still not ejected and drutil eject gave these results:
dyld library not loaded: /system/library/Frameworks/OpenGL.framework/versions/A/openGL
referenced from: /system/library/frameworks/QuartzCore.framework/versions/A/Quartzcore
reason: image not found
Trace/BPT trap


Try this:
Shut down your computer.
Turn the power on with the power button and hold Command-Option-O-F – this will boot you into open firmware.
Now type eject cd and wait until the CD pops out. Type mac-boot and of you go…

– Peter –

the Aluminium iMac is Intel-based and doesn’t have Open Firmware :wink:

Another suggestion:

Hold down the mouse during boot.
I tried this a while ago with an Intel Xserve - and it worked.


Feels like college exams week, here … learned more about the machine in past 24 hours than in past year. I do thank all of you for your input.

Still unable to boot the system; ejecting the CD is secondary, although it would be nice to utilize the tools on the Install Disk 1 … sigh.

Currently in single user (read only) mode (CMD S on startup, then sudo -s). I’ve run fsck -fy which indicated volume is ok. How can I remount the boot volume … via bless, perhaps or do I need to run a more complicated start up script for OSX 10.4.11?

This is just a shot in the dark…
I don’t know what kind of CD/DVD you are unable to eject.
Maybe your Mac is trying to boot to it (to some degree).
Try restarting & hold down the Option key until you get the screen to select a drive.
See if the CD/DVD is selected.