Panther and Photoshop (7.01)

Installed Panther, everything v. lovely until I tried running some of my photoshop scripts. All changed - none working - and Photoshop’s dictionary reduced to the Camera Raw plug in. I’m sure I’m missing something, but havn’t found any obvious answers - please help! Thanks.

Have you installed the Photoshop 7.0 Scripting plug-in?

– Rob

Thank you Rob - it was installed in 10.28. Panther installation (archive and install) must have got rid of it - reinstallation did the trick. :smiley:

I’ve read about this issue before (it also seems to effect QXP) but I did an Archive & Install upgrade to 10.3 and all of my plug-ins came through in their correct locations. I wonder what the difference is.


PS Rob, when I go to [url=][/url] I get a “File Not Found” error. I also get this when I directly link to this page from Adobe’s own link ([url=][/url]).

Hmmm. I just tested both links and they both worked. Strange.

– Rob

I think Adobe is having problems with their site. A forced refresh returns an incomplete page with a textual link bar and nothing else.


The scripting installer installs a scripting addition called Adobe Type Units in /Library/ScriptingAdditions, and this gets lost in the Panther update. Something similar happens with QuarkXPress 6.

Shane Stanley

I recently upgraded my OS to panther and follwed the hint posted in this topic and when i open the PS dictionary this is all i see:


Required Suite: Every application supports open, print, run, and quit

open a list of alias
[manage to string/nomanage/unmanage] – URL for server to manage file(s) against.

Photoshop Suite:

do script: Play the specified Action.
do script string – Name of action or actual action to execute
[with a list of alias] – List of files on which to run the action. If this parameter is not present, the script is run on the active document for use only by droplets
[override open boolean] – Override open commands in the action for use only by droplets
[include subfolders boolean] – Process subfolders of folders dropped on the droplet for use only by droplets
[override save boolean] – Override save commands in the action for use only by droplets
[save and close boolean] – Save processed files over originals for use only by droplets
[save to alias] – Save processed files to this folder for use only by droplets
[log alias] – Error log file for use only by droplets

–=========END quote===============

I seem to remember more items in the dictionary before

Am i wrong?
I checked the “Adobe Unit Types” file is in the scripting additions folder in the library and the “Scripting Support, Scripts Dialog” files are in the scripting sub-folder of the PS lug-ins folder
any way this has caused one of my scripts to no longer function

on open theList
	set source_path_thumbs to "Macintosh HD:Users:jbradfield:Desktop:move to MktThumbnails:" -- Temp location to save jpg file to
	set target_path_thumbs to "DEPTS:CHEMICON:Marketing:Literature:Thumbnails:" -- Target ddestination for jpg thumbnails
	set target_path_pdfs to "DEPTS:CHEMICON:Marketing:Literature:PDFs:" -- Target path for the PDFs
	repeat with i in theList
		set theinfo to info for i
		if file type of theinfo is not "XLS8" then
			set chosen_file to i as alias -- (choose file) as alias -- Choose your PDF file here
			set current_name to displayed name of (get info for chosen_file) -- Get the name of the PDF file
			tell application "Adobe Photoshop 7.0"
	open i as PDF with options {width:3, page:1, resolution:72, mode:RGB, constrain proportions:true} -- open the pdf as a 72 dpi thumbnail
	flatten document 1
	--save document 1 in (("DEPTS:CHEMICON:Marketing:Literature:Thumbnails:" & current_name) as file specification) as JPEG with options {quality:5} appending lowercase extension with copying
	save in "DEPTS:CHEMICON:Marketing:Literature:Thumbnails:" & current_name as JPEG with options {quality:5} appending lowercase extension with copying
	--do action "PDF Thumbnail" from "Saver Actions.atn"  -- this works but the actions would have to be installed on the host computer running the script
end tell
			tell application "Adobe Photoshop 7.0"
				set «class AUiL» to «constant e050Nevr»
				open chosen_file given «class fltp»:«constant OpAse021», «class FmOp»:{«class Wdth»:3, «class pPgN»:1, «class ResL»:72, «class OMde»:«constant e900e082», «class CPrP»:true} -- opens the PDF as a 3" wide 72 dpi image
				tell «class pADc»
					«event 8BIMFltn»
					save in ((source_path_thumbs & current_name) as file specification) as «constant e320e006» given «class FmOp»:{«class Qlty»:5}, «class DcXt»:«constant e300e301» --saves the jpg to the temp location
					close saving «constant e400no  »
				end tell
			end tell
				mount volume "smb://"
			end try
			do shell script "cp " & (quoted form of POSIX path of chosen_file) & " " & (quoted form of POSIX path of target_path_pdfs) -- copies the PDF to the PDF destination
			do shell script "mv " & (quoted form of POSIX path of source_path_thumbs) & "* " & (quoted form of POSIX path of target_path_thumbs) -- moves the files from the temp folder to the Thumbnail folder
		end if
	end repeat
	tell application "Microsoft Entourage"
		make new outgoing message with properties {recipient:"", subject:("New Literature" & current_name), attachment:(theList)}
		set messID to the result
		send messID
	end tell
end open

on run
	set p to choose file with prompt "find me a PDF file"
	set x to choose file with prompt "find me a xls file"
	set y to {p, x} as list
	open (y as list)
end run

my script errors out now obviously because it can not find the dictionary items

any ideas to help on this one


You can download a PDF version of the PhotoShop dictionary at:

I don’t have PS so I can’t offer advice. Good luck!

– Rob

Just being able to see the dictionary won’t quite do it for some reason the dictionary items are unavailable for use on my system (though all the appropriate additions/plugins are installed – at least I think they are!)

I knew that the PDF wouldn’t help fix the problem but I thought you might want to take a peek to confirm that, as you suspected, there is more to the dictionary. :slight_smile:

– Rob

Thanks rob
I am Sorry After i re-read my post it did seem sort of SHORT (rude)

But as I suspected and you helped me to confirm My Photoshop dictionary is short a few entries

Maybe someone else has some ideas why PS scripting seems to be inactive

Powerbook G4 Dual 1.25
Firewire 800 (silver drive doors)
OS 10.3 Build 7B85


Did you take a look at Rob’s reply at the beginning of this topic? You need to install the scripting plugin for Pshop to have the complete dictionary. You can get it from Adobe’s website.