Problem with speakable scripts

I search everywhere without any luck.

AllinOne G3, OS X 10.2.8, scripteditor 1.9
PowerBookG4, OS X 10.3.8, scripteditor 2.0

Script tested but the problem is the same with all scripts I have tested:
tell application “Finder”
display dialog “It works!”
end tell

When I save this script using the editor 1.9 on the G3 or G4 (as compiled), move it to the “speakable items” folder, the script runs in response to the spoken command.
If I do the same with the editor 2.0, the speech recognition recognizes my spoken command but the script never runs! The scritp runs if I run it manually.
I tried all the possible options on how to save the script without changes. I also used FileExaminer to compare the same script saved with the 2 different versions of the editor and I cannot see any difference that can explain why the script does not run with the version 2.0 (same owner, permissions, type/creator). The only difference is the size of the file (4Ko with 1.9, 8K with 2.0).
What’s different between the version 1.9 installed by 10.2 and the version 2.0 installed by 10.3? Is it a bug?
Help will be greatly appreciated