problem with "system_profiler SPApplicationsDataType" which returns ""

I tried to run an old script which worked in the past.
As it gave an odd result I studied its different parts and discovered the problem.
Here is the stripped code:

set startTime to (time of (current date))

set fullReport to do shell script "system_profiler SPApplicationsDataType"

set executeTime to (time of (current date)) - startTime

It take 3 minutes to return “” which is really not what I was assuming to get.

Am I doing something wrong ?

I just discovered that when I try to get System Infos from the apple menu and ask for “Applications” I get : “Le module n’a pas répondu suffisamment rapidement lors du recueil de ces informations.”

Yvan KOENIG running High Sierra 10.13.6 in French (VALLAURIS, France) samedi 8 février 2020 16:17:03

What time do you get in Terminal ??

I got less 20sec on my MacBookPro from 2012

4 seconds and one fine full report on my Mojave system. Tested your script as is.

2 seconds here. I ran Yvan’s script from within Script Editor, and rebooted before doing that. The application-data output was as expected.

Thank you to all of you.

I got the explanation.

I didn’t took care that several external HD were connected to my iMac and I forgot that the triggered instruction search the applications available in every attached devices.
Now the extraneous devices are gone.
The script scans only the two mounted devices : the SSD from which I boot and the internal mechanical HD.
Now it took 38 seconds.
I found no way to search only in the SSD.

Yvan KOENIG running High Sierra 10.13.6 in French (VALLAURIS, France) dimanche 9 février 2020 16:13:54