Problems building Xcode plugins

Hey, everyone.

I’ve decided to pick up work on my ‘Chronicle’ xcode plugin again, but I’m running into a bit of a problem. I can’t seem to get xcode to build an applescript xcode plugin that will successfully load. It builds successfully, but when I restart xcode I get a couple errors in console, and the plugin is never loaded.

The error I can not reconcile is…

If I install some of my old xc1.5 plugins, they work fine. If I open those old projects in xc2.0, rebuild them, and install them they are broken.

The second error I get, which I was able to fix was…

I opened my app’s plist and manually entered the key with the same value (“YES”) as the apple plugin’s have, and the error went away.

This leads me to believe that apple is just dragging their feet on providing support for the plugin architecture. They are not configuring the plugin properly at build-time, or have not accounted for changes in how xcode handles loaded bundles. Perhaps the 2.1 update to xcode has fixed this problem? Can anyone else, either with 2.0… or better yet with 2.1… confirm that this is universal behavior? I’m on dial-up for a bit, so I can’t download the xc2.1 update right away, so I’d appreciate knowing if anyone else can reproduce this problem.

Thanks to all who can respond…

If you can give me something to compile, then I could try it in Xcode 2.1.

Bruce, thanks for the offer.

Actually. I was able to get to a highspeed connection and download 2.1. I created a test plugin project, and HOORAY, it worked! The strange thing is that when I tried to begin working on my actual project, it continued to throw errors. My project name is “Chronicle”, and no matter where I save my project or what the project contains, it ALWAYS fails to load, just as before. I’ve tried a half dozen different Chronicle versions, all with varying levels of complexity, location, etc. If I name it anything else but ‘Chronicle’, it loads right up. I’m completely stumped as to why this is happenning. It seems almost as if xcode is caching references to names of plugins that have failed to load before, and ignoring them on future attempts based simply on their name. There’s nothing wrong with the project, it just doesn’t like the name. :rolleyes:

Fortunately, I am able to load simple plugins by other name’s… which is a step in the right direction… so I’ll try to start adding features and see if I’m able to get everything done I want to. If anything, I’ll just have to come up with a different name for my plugin. :frowning:

Oops. I forgot that in all of my tests and troubleshooting, I had deposited a copy of my disfunctional plugin in my plugins directory in my user library. I assume Xcode launches user plugins before it launches global plugins, so the broken version was cancelling out the new version I tried to put in my main library. So, all of my plugins are now working. Duh! :stuck_out_tongue:

Thanks again,