Quark dictionary can't open...

I’m trying to write a script for Quark 6.5. When I try to open one of the sample scripts that came with Quark, Quark launches, and then I get an endless pinwheel when the script tries to open in Script Editor. If I quit Quark, then the script opens, but if I try to compile the script, it tells me that Quark is not running.

I’ve tried opening the Quark dictionary in Script Editor and had the same result. I’ve tried this on other computers at work, and it works fine. Any ideas?

If it helps, I’m using Script Editor version 2.1.1 (81)… if that makes a difference? Applescript version 1.10.7… Running on OSX v 10.4.7
I have tried deleting my Quark preferences, but that didn’t seem to work.

Thanks in advance for any suggestions!

Model: G5
AppleScript: 1.10.7
Browser: Safari 417.9.3
Operating System: Mac OS X (10.4)

Check your scripting additions folder to make sure the file QXPScriptingAdditions.osax is installed, I don’t think it will work without this.

Thanks Jerome. I took a look in my scripting additions folder, and I did find the QXPScriptingAdditions.osax file.

I think I figured out what the problem is, I just don’t know if there is a way to fix it. My version of Quark is part of a 10-user pack, and the license is on a server. I think that Applescript can’t resolve the license issue, and it hangs and times out.

The other computer that I tested on has a stand-alone version installed on it. And everything works fine, but on all the computers that have the multi-user license, it doesn’t work.

Thanks again for the help.

I haven’t had that problem using Quark at work, and we have a lot more than 10 licenses in our network’s database for Quark. If Quark is running AppleScript should be able to send it commands. My guess is that there is something else wrong.

I’m not really sure what else it could be. We have 3 computers that have local licenses and 6 computers that use a license that is located on our server. Applescript works with Quark on the 3 computers with local licenses with no problems. But none of the other 6 computers work. Maybe it’s something with the way the license was set up… I really don’t know. And the system admin really doesn’t seem to know much about this stuff, so he’s not much help.

Thanks for the response. If you can think of anything that I could try, I’d be happy to try anything. There are a lot of script that I wanted to write for Quark.


EDIT: I thought of one other thing that is really weird. If I launch Quark first, then I can open the dictionary in Script editor, and run scripts on all computers except one. When I run a script on that machine, it gives me an error message saying that Quark doesn’t understand the exists command. But that is clearly in the Quark dictionary. And why would the same script run on all machines except one? I can’t figure it out.

Hi Please check your preferences folder.

Which OS version you are using?(check through About)
Which QuarkXpress version you are using?(check through About)

Do one thing, Launch Quark first, then launch Applescript and write a small program and compile it. If it works fine, then open the script which you want to compile. Copy all content and paste it in the compiled script except First line i.e. Tell Application “QuarkXpress”.

And now compile, if problem still exist, then send me the code, or tell me which default script you want to open.


Hey Macrajeev,
Thanks for the responce.

I’m using Script Editor version 2.1.1 (81)… if that makes a difference? Applescript version 1.10.7… Running on OSX v 10.4.7. QuarkXpress v6.5

I have successfully written a ton of scripts, it’s only when I add the “tell application “QuarkXpress”” line that I have any problems. I’m not at work, so I don’t have the script in front of me, but if you look in the scripts folder in the QuarkXpress folder, there’s a subfolder that I don’t remember what it’s called. But the script that I was trying to run is called “Add Crop Marks”… I think that’s the name.

It runs fine on all the computers except one. I just can’t figure out why it won’t run on that one. If you can think of anything, I’d appreciate it.


For anyone interested, I e-mailed Quark’s tech support, and they gave me an Extention that solved the problem.