Quark script broken - set image 1 to alias x

: I have a script that used to work. I don’t know if it’s because
: of OS 9.2 or what.

I tried the following variation and it worked under 9.2:

tell application "Finder"
    set the_photo to the selection as alias
end tell

tell application "QuarkXPress? 4.11"
    tell document 1
        --[ some stuff ] 
        tell current page
            --[ more stuff ] --> 
            set image 1 of picture box 1 to alias the_photo
        end tell
    end tell
end tell

I don’t know why it’s not working for you. Is the picture box actually named “One”? Is the_photo an actual alias? Did you try just rebooting?


Yes, the box is actually named “One.” I have 2 photos per page with 2 captions and a page footer. I had problems with the text going in the wrong boxes so that’s why I named them.
This script worked in OS 9.1. I recently installed OS X and OS 9.2 and it works in OS X, but not in OS 9.2.
(I have this within a “try” statement so it won’t stop on an error. I just see the results in the event log.)
And come to think of it, it might not be working in Quark 4.1. I’ve been going back and forth between 4.1 and 5.
I can post the entire thing if that helps. (I don’t have it with me now.)