Running Script in Entourage Script Menu

I have developed a script for doing a bunch of stuff in Entourage. (Yay! my first script). When I run it standalone, (from within the script editor) it works fine. But when I try it from the Entourage menu, I get an error dialog “The script could not be run. The end of file was reached.” (Or sometimes, “An error has occurred, (-192)”.

I tried saving the “about this menu” (from Microsoft) script under a new name and running it, and got the same error. So I conclude the problem is not with the code itself. I am saving it as “compiled code”. I’ve also tried it, saving as “run only”. Same error each time. I’m wondering if my version of ScriptEditor is too old. I’m using version 1.9

In the same vein, I’m a little confused as to what version of the development system is possible for me to use. I’m back an OS version: I have 10.2.8

Thanks for any and all help



I’m working on an Entourage script myself.
I discoverd that you can’t do everything with applescript when you run it from within Entourage.
I needed to relaunch Entourage and this isn’t possible within Entourage (which seems logical) but running it via the script editor works fine.

Perhaps you’re looking a the same problem.