Save new Movie Quicktime Pro

I create a new movie. paste some content in and would like to save it, but I get always timeout/error message without quicktime player visibly doing anything.

I can however export the said new movie, I still get a timeout (if the file is large), but the export goes on neverstheless and eventually I get the new file.

This works:
select front document at inpoint to (inpoint + selection_length)
cut front document

	make new document --at ("Macintosh HD:private:var:root:Desktop:Vod_Mainfile")
	paste front document
	export front document to file ("Macintosh HD:private:var:root:Desktop:" & filebezeichnung) as QuickTime movie
	close every document saving no


This fail:
set the target_file to (“Macintosh”)
save front document in target_file as self contained

Adding as alias tied too but to no avail.

Any hint how this could work? I even tried with a very very small web movie and no success.

Perhaps someone sees where I overlook the obvious!



Hi Ute,

The problem is, there’s a bug in QuickTime 7.2 which breaks the save . as self contained command.
The only solution is to go back to QT 7.1.6

read this thread in the Apple Discussions

Hallo Stefan,
Thanks a lot! The environment where the script will be running in the end is a 7.1.x environment.

So it will be working there with save and that is good news!

Viele Grüße in die Schweiz!