Save TextEdit document without .rtf extension

Help !

Got this script :

set destpath to “/Volumes/JobFolder/” as string
set theFile to destpath & “123888ferr”

tell application “TextEdit”
make new document
save document 1 in theFile
close document 1
end tell

It makes a blank text edit file for me - but the resulting file is named as “123888ferr.rtf”

How can I get it to save the file without “.rtf” ?

I’ve tried a few things - but so far without success.

Grateful for your help.

You can’t.

You’ll have to rename it after saving:

set this to choose file

tell application "Finder"
	set name of this to "test"
end tell

I must say I have doubts as to its usefulness…

gidday swardle72

why not goto Finder/Preferences/Advanced and disable “Show all filename extensions”

Maybe he wants other files’ extentions.

Anyway, I agree that renaming it in finder would work. If you have 10.4 Tiger, you could make AppleScript click the “Hide Extention” button.