Saving as Run Only

Hi there,

I’ve found some posts on that subject but can’t get it to work. So What I need to do is to save my ASS app with the script file unreadable. Posts suggested that building in Release mode would automatically compile the script file, but it doesn’t do the trick for me. I’ve also played around with the FileType in the Info Window of the script file, tried a couple of formats, like “Compiled” or Compiled.mach etc to no avail. Also, the past posts direct to Xcode Menus that don’t exists anymore…




Ok, so, weird weird but here’s the deal:

I’ve found another xCode project that indeed has as build phase “Development” and “Deployment” just like described in other posts that talked that issue. I can with that particular project build scripts as Read Only. In my original project I have “Debug” and “Release” as build phase (with which I cannot save Run Only scripts). Changing the names of build phases obviously doesn’t help… there must be a setting somewhere…

Once you compile your project in “Release” mode, go to it’s directory, then “/build/release” and you will find the file that you give to people. Just zip it and upload it somewhere. The files outside of that folder are just for your convenience. Nobody should be able to read the source if you just give them the file I mentioned.

I hope that solves your problem, or maybe there’s something I’ve missed.

Hi Lambo,

thanks for taking the time to reply. No, that’s not what I meant, what I mean is that the Script file in the app package is not saved as run only. Anyone can go to Show Package Content and get the script, that’s what I meant.



That’s how it supposed to work. If that project is the only one you’re having problems with, then I would just open the script (that’s inside the finished app) in Script Editor and manually save it as Run Only.


thanks for your response, that’s not working either because Script Editor cannot compile ASS handlers, no go…

If you open it in Script Editor, do you see stuff like this?

on «event appSwiFL» theObject
	-- This is the "will finish launching" handler
end «event appSwiFL»

That will compile and save. Are you sure you’re opening the right (.scpt) file?


in the quest of saving as run only I have encounter the terminology you are pointing. However the situation now is that I have an .applescript file which compiles as a run only in a project I’ve found on the web. Suffice I use the same script file and nib in a new project for it to save as plain text… It must be something in the build settings, I’ve tried comparing the settings but there’s too much I don’t grasp. Fact is, if you use the default setting for an ASS app you will not end up as a Run Only Script…


Hi Micha

I too missed the “Deployment” after read somewhere about the existence and meaning of this Configuration. (I do speak almost fluently English but not in Computer Terms, since I speak and think in (Swiss)-German ) I did not find it in my Xcode-Version nor any Explanation, why it is not present (anymore) and was wondering why so many wrote about a non-existing Configuration. After some thinking I had the Idea to check the Project menu and … here is my solution:

Menu “Project” => “Edit Project Settings”
Click Tab “Build”
Enter in the Searchfield “deploy…”
Activate the button behind “Deployment Postprocessing”
Click Tab “Configurations”
Duplicate any Value
Rename to “Deployment”
Now you can select Deployment in the PopUp Menu