Script from FileMaker running on Lion errors

We have a script that runs a calculation that is an Applescript, and have been for the last year. I suddenly have one new system that will not run the script and it has Lion on it. All other systems are either 10.6 or Win 7. Is there a problem with Applescript and Lion?

I receive the error “A “”” can’t go after this identifier" and then “Unknown Error -2740”. I have pasted the line below. If you Compile in Script Editor you will get the same error.

tell application “FileMaker Pro Advanced” to set cell “Applescript Completed FSR Result” of current record to errStr

Let me know if you need any more info.

First track :
as you are running Lion, try to edit the FileMaker document by hand.
Maybe you got the warning “the file wasn’t used for a long time so it’s locked”
As it’s a new feature, maybe the app is unaware of that and return an inaccurate error.

Yvan KOENIG (VALLAURIS, France) jeudi 15 décembre 2011 17:06:49

Shouldn’t “set cell” be “set data cell”?

Thanks for the reply but as I said I have 6 other systems (10.6.x) running this DB all day and running the same script multiple time with no issues. The only error I am receiving is the one mentioned below. If you past the AppleScript line in Apple’s Script Editor on a Lion system and Compile it will give the same error, I’m pretty sure. I only have one Lion system here to test it with.

Kerflooey, I do not know, I’m do not write AppleScript. That is why I need any help I can get. I will try that and let you know. Thanks

Is your new computer running the same version of Filemaker as the older ones?
Because in FM11, there is an Applescript bug that sometimes it won’t return properly because some things run asyncronously, and you have to add an extra delay or sleep command to a script. It may also depend if it’s an external script, or internally stored Applescript.