Script not working in Cumulus 6

I have a basic script that was written in OS-9 for Cumulus 5

Now that im in 10.3.2, the script does not work at all. Cumulus quits immediately upon execution and gives an error of “connection not valid”.

I tried to open the Cumulus 6 dictionary to see if any of the objects/commands had changed since I noticed that in a prevous posting. The Cumulus dictionary has only two listings and basically only lists the open and quit command. Where is the dictionary?

Here is the script:

tell application "Cumulus"
	tell front window
		set imagecnt to count record
		set counter to 0
		set currentRecord to 1
		repeat until counter = imagecnt
			set recordname to name of record currentRecord of selection
			tell application "FileMaker Pro"
				show every record
				get cell "Notes" of (every record whose cell "Image Name" is �
				copy result to recordnotes
				get cell "Photographer" of (every record whose cell �
					"Image Name" is recordname)
				copy result to recordphoto
				get cell "Subject" of (every record whose cell "Image Name" is �
				copy result to recordsubject
				tell application "Cumulus"
					tell front window
					copy recordnotes to field "Notes" of record currentRecord of selection
					copy recordphoto to field "Photographer" of record currentRecord of selection
					copy recordsubject to field "Subject" of record currentRecord of selection
					set counter to counter + 1
					set currentRecord to currentRecord + 1
					end tell
				end tell
			end tell
		end repeat
		display dialog "Transfer of data has been successful."
	end tell
end tell

Any help understanding why this won’t run in OS-X would be greatly appreciated.

Apple Script is not supported in v6 Cumulus. You’ll need to do EJAPs.

Have a look at Cumulus/Sample EJaPs/ApplescriptCumulus6EJP.txt to see how to send java commands from a script.

Thank you for that info but I am not clear as to how to follow that path to get this text file explaining EJAP handling.

How do I find this document at : Cumulus/Sample EJaPs/ApplescriptCumulus6EJP.txt

I searched the bbs but found nothing.

Many thanks.

Look in your applications folder on your hard drive. Is Cumulus 6 installed there? Is there an EJAP folder inside it. If not, re-install.

I guess this is now a java question but I found the EJAP info and am calling these commands as they instructed however:

this is the example they give ot get a record field:


e.g. getFieldValue#demo#0#Notes


this actually gets a field value but only for the whole catalog, not the current collection. Their example only uses a record number, not a collection number. The record number needs to be qualified by a collection and it wont take it in any of the forms I have tried:

can anyone help me with this part of the java command

I can put in a number between the #s and it works but gives me the first record of the entire catalog, regardless of the current collection showing.


I need it to find the first record in the current collection and nothing works. What parts of the example are to be included in the command between the #'s?

Ive tried:

#recordnumber {0}|CollectionID{1}

I guess I have to learn java to use Cumulus. Thanks.