secondary script targeting Studio app compiles with raw events

I have a secondary script residing in the bundle of a studio app that all of a sudden won’t compile in AS Editor. Or rather it compiles, but with any classes referring to Studio objects showing as raw event syntax:

for example:

tell application "myApp"
		«event appScalM» "synchronize" given «class of O»:«class useD»
			tell «class taVI» "maintab" of «class tabV» "maintabs" of window "main"
				set «class enaB» of «class butT» "testbutton" to false
end tell
end tell

I tested this and it’s the same problem with a new script targeting this app.

However, the problem doesn’t occur with two other studio apps I tried, just this one.

What broke and how can it be fixed?

I tried restarting of course, to no avail. :frowning:

Model: MacPro
AppleScript: 2.1.2
Browser: Safari 525.27.1
Operating System: Mac OS X (10.6)

well… no sooner did i post that than i figured it out. i had inadvertently unchecked the “scriptable” property on the Info.plist, I think. re-checking that and then quitting and relaunching script editor fixed it. doh.

thanks for looking. :wink: