[SOLVED] filemaker: 'cell foo starts with...'

EDIT: ha, success!
guess I did not search hard enough!
thanks to Camelot for the info on doing requests.

if I have a text cell foo in filemaker (5.5 server and client), why does searching for foo starting with “A” return records of foo like “Abracadabra” but also “Wacky Anglophiles” or even “Help A Brother Out” …?! (i.e. not just those starting with A but in fact all records whose cell foo contains space+A somewhere in them…!)


property alphaList : {"A", "B", "C", "D"} -- etc.

tell application "FileMaker Pro"
	open "bar.fp5"

	repeat with alpha in alphaList

		show (every record of database 1 whose cell "foo" starts with alpha) -- also tried (alpha as string) for the heck of it, no dice
		--do some stuff
	end repeat
end tell



anyone? bueller?

so I noticed that this problem is not just with ‘starts with’ but also ‘equals’…!?

e.g. if cell foo of my database contains:
“bar brady”
“boo bar bong”


show (every record of database 1 whose cell "foo" = "bar")

will return all three of those records!

my workaround up to now has been the stupidly obvious:

--after the 'show'
set tempVar to cell "foo" of the current record
if (tempVar = "bar") then
-- do stuff ...
end if

but it’s still really annoying that I can’t do exact matches against filemaker. isn’t there some kind of qualifier or flag to ‘show’ that would allow this?