Something weird is happening

All of a sudden I have started losing class files within Interface Builder.

In projects that have been working with no problem as soon as I recompile with something as simple as adding a space and then removing it in Xcode when I open the xib in Interface Builder the class has disappeared from the class list.

I have tried “reload class files” in interface builder.

I have tried “read class files…” in interface builder.

I have removed Xcode and reinstalled.

I have created a new project and transferred the applescript files and xib file.

Even when I create a new project and add a new class applescript it does not show in Interface Builder. Even the —AppDelegate does not show in interface builder.

I am completely at a loss as what to do next.

Can someone help please?

I am using Xcode 3.2.1 and interface builder 3.2.1

All the best


That’s normal – you have to add them manually.

That’s not normal. You’re not using a project name that you’ve used before, are you? That can sometimes cause confusion, with the wrong .xib file being opened.


Thanks for your suggestions.

You say that’s normal. I do not think so because I have class files created in Xcode that have automatically populated the pop up list of available classes in Interface Builders identity section of the inspector pane.

Even when I type it in by hand it does not populate the list.

It does retain the name but it does not have any outlets or references and I cannot drag to it or from it in Interface Builder. It will drag but will not highlight any objects.

I have tried both new projects and existing names to no avail.

Have you any other ideas?

All the best



Replying to myself but I just had a suggestion from the AppleScript Studio mailing list.

This seems to have worked.

Copied the script text to the clipboard from Xcode

Closed Xcode

Opened AppleScript editor

Pasted the text from the clipboard into AppleScript editor

It obviously would not compile.

Saved it as a text file “untitled”

Renamed it to the same as my problem file.

Replaced the file in the Xcode project folder with the file created in AppleScript editor.

Restarted the project and it now appears in the Interface Builder class list.

I will now reconnect everything. If I do not repost then everyone can assume this works.

Why did it happen. I cannot be sure but I wondered if it was because of the AppleScript I have created for commenting the text automatically?

Any ideas? It may be worth avoiding the scripting dictionary of Xcode?

All the best


PS. for Shane. It populated the Interface Builder class list automatically.


It does seem to have worked.

What I did notice in addition was that I had inadvertently changed one of the prefs of Xcode “Text Editing” the line endings section to Mac (CR) from Unix (LF).

This may also have corrupted something.

I have set these to Unix (LF) and now all seems well.

All the best