Sparkle in ASobjC Project


I’m having some weird problems with Sparkle 1.5b6 and my ASobjC project. Following the instructions to the tee. Worked the first time and now I’m getting the following error:

Cannot access memory at address 0x0

Console shows:

dyld: Library not loaded: @loader_path/…/Frameworks/Sparkle.framework/Versions/A/Sparkle
Referenced from: /Users/jvincent/Documents/2ndSegment/SkyCal/ASOC/SkyCal copy/build/Debug/
Reason: image not found

I’m using the garbage collected framework as was posted here. Any ideas? Anyone using Sparkle in their ASobjC app?


On further analysis, looks like the Sparkle framework isn’t being copied. Anything I can check in the copy files build phase? I created a new test app and set it up per the documentation. Same error and there was no Frameworks folder in the built app. I added Sparkle.framework and enclosing Frameworks folder to the package and it ran.

Well, after much frustration and research I found my problem. Maybe I can save someone some time: These are the instructions from the Sparkle Documentation:

A rookie mistake on my part: I was dragging Sparkle.framework to the path field of the phase editor and not directly to the Copy Files build phase in the Targets tree.