Speech Cmds in Mavericks/Yosemite

I am about to upgrade OSX from Lion 10.8.5, but am afraid of losing speech commands
Can anybody who is on Mavericks/Yosemite check the folowing script and report the results

tell application "SpeechRecognitionServer"
   set theResponse to listen for {"yes", "no"} with prompt "Hello. Do you like me?"
   if theResponse is "yes" then
       say "I like you, too."
       say "I don't care whether you like me or not."
   end if
end tell


Hailing from Yosemite I received a dialog the first time I ran the script. The dialog said “A 1.2 GB download is required to use speech recognition feature in SpeechRecognitionServer” and I received this error:

“error “SpeechRecognitionServer got an error: Connection is invalid.” number -609”.

However once I downloaded the 1.2GB file and reran your script and everything worked great! So upgrade away.

Using Mavericks 10.9.4 Mac Book Pro 15" Late 2013
sweet as, no down load of anything required for the code to work for me.

I am bringing this post back to life because I am getting this problem with Catalina.

You say I have to download a 1.2 GB file? Where? The error doe not show any URL where I can download that.

The script refuses to run telling me that a “0 bytes file needs to be downloaded”.

I am trying it with the Portuguese (Brazil) language.

Any ideas? thanks.

Hi macos_boy.

I don’t know the answer to your question as I don’t have Catalina and don’t talk to computers. But in Mojave, the first thing I’d try (if you haven’t done so yourself already) would be to go to the “Keyboard” pane in System Preferences, click the “Dictation” tab, enable “Dictation” and “Enhanced Dictation”, and select Brazilian Portuguese in the Language Menu. It looks as if the system would take care of the necessary download for you. I’m guessing this is the download referred to above, but, as I said, I don’t know.

On my Mac (Retina 5K, 27-inch, 2019) with Catalina 10.15.7 works perfectly.

I tried to run the script in the OP and “Speech Recognition Server” hangs and fails to raise the prompt. This is Mavericks.

Model: MacBook Pro
AppleScript: 2.3.2
Browser: Safari 9537.86.7
Operating System: macOS 10.9