Strange application behaviour

for some months, i used to run one of my applications from the /Applications/Utilities/ folder.
Strange things happened the last two-three weeks, because now this application refuses to launch, from the Utilities folder (I’m always on Snow leo).
If i move the application back to /Applications/ and forth again in the Utilities folder, the application starts like ever.

I get this error:

-->error "LSOpenURLsWithRole() failed for the application posix_path with error -10810." number 1

i tried to resolve the strange error, but i had no luck for now, using:

do shell script "xattr -d -r '" & posix_path & "'" do shell script "chmod +x '" & posix_path & "'"

Maybe you have had a corrupted cache entry of some kind; that Launch Services has had, that got overwritten when you moved it back and forth. (Maybe you copied the app into the utilities folder the first time, so you had two apps with the same UrlRoleHandler?)

This is just a wild guess.

if McUsr is right you can check it by updating the launch services database, this can be done with lsregister. If the problem is solved you have indeed an cache/update problem.

:slight_smile: I didn’t know about that one! I found a great blog here, describing it, as it comes without a manual: lsregister: How Files Are Handled in Mac OS X |

And by the way, if is should so, that Spotlight ever stops working, and you can see in your that you are having conflicts, then it may help to clean out the caches before rebuilding the Spotlight database.

This is not totally related to the above, but Spotlight problems in my experience, can point to cache problems, and vice versa.

I’m using the dump option to get application and launch services information.

Thanks alot! :smiley: