Strange problem in choose file

AS you may know my Dialog Maker app produces user interaction AS code, it has a feature that lets you preview the result without the code, when I run something like:

choose file with prompt "prompt" of type {"txt","xcodeproj"} default location (path to Home folder) as alias invisibles true multiple selections allowed true showing package contents true

I get these logs in Xcode while browsing, however they are not errors in the sense that they don’t halt the subroutine:

Try entering and exiting package files, xcodeproj ones in particular (related to my allowed types?), just double click an app or other package, then browse around inside, then exit with the back button or by selecting something in the sidebar. Happens to me anyway. I tried it in AS Editor, but nothing happens except hangs, perhaps a different way of showing the same problem.

Not sure where you’re talking about

choose file with prompt "prompt" of type {"txt", "xcodeproj"} default location (path to home folder) as alias with invisibles, multiple selections allowed and showing package contents

Works exactly as defined. The reason why I can’t choose the “xcodeproj” is simply because the show package contents property is turned on. I can go back and forth without an problems too.

In Xcode? Do you get no logs?

No I’m sorry that i don’t get an error ;). I pasted the code in an awake from nib handler in an existing project of mine and works like expected, also no errors in the console.

What I did was copy your code, paste it in applescript edtor, compile it (that’s why my code looks slightly different than your) and then paste it into my xcode project. Then run the project and see a very nice choose file dialog. I’m using xcode 4.0.2 and 10.6.7.

Ahhh, I’m on Xcode 4.2, perhaps it’s a bug.

Wait until you see what Lion and Xcode 4.2 make with file wrappers. :stuck_out_tongue:


I don’t know what file wrappers are to be honest. Were you just hinting it’s worse? haha