Syntax colouring has stopped working

In XCode 2.0 in Tiger. My Applescript code used to colour and indent itself automatically when I compiled the application. Now the code is just all black text. As I enter new code it is entered in purple, but never recolours or formats itself. If I save then close and reopen the project, the new purple text has turned black.

In the format menu, Syntax Colouring is set to “Default for file type” with a little dash next to Applescript. I tried selecting Applescript to put a tick next to it, but it made no difference.

The syntax colouring still works in Script Editor. I’ve tried Googling and searching the forum here and MacOSXHints but I can’t find anything.

Any thoughts?


Hi Mark,

We all seem to have the same problem, more or less.

Please see the exchanges in the post below by deanshavit about lost syntax coloring.

I hope we all find a way to go about this problem.


Hi archseed

I didn’t see that post. To be honest I haven’t look that hard recently after I spent hours searching a few weeks ago :slight_smile:

My app is quite large too, and the syntax colouring stopped working after I pasted a large chunk of code in to the source. I guess it must be a bug in XCode then! :frowning: