tell Application changing to "Finder"

I have a strange issue that arose yesterday. I had to rebuild my OS, 10.10, and since then I can’t edit some scripts that uses an Adobe CC InDesign version. Handlers that normally call InDesign now call the finder. That is, my code changes from
tell application “Adobe InDesign CC 2015” to
tell application “Finder”.
This only happens with InDesign CC programs, not InDesign CS6. Photoshop CC is okay. I even tried to restore a file from a month ago, via TM, and that file opened the same way.

I have rebuilt everything on my computer. I have tried editing code in Script Editor, Script Debugger, and ASObjC Explorer 4, same results. I have made sure to open my related programs first, and then opened the dictionaries before opening the script, still same result.

Because all my tell statements are wrong I get <> and <> all over the place. All my applications are working properly, but I may have to rebuild some of my scripts from scratch.

Any suggestions appreciated.

Model: MacBook
AppleScript: 2.4
Browser: Safari 600.8.9
Operating System: Mac OS X (10.10)

Update to issue. I was able to make a dot applescript text version of my code on another computer. I then copied that to my computer to see if it would compile. It also changed to tell application “Finder”.


Have you tried rebuilding your Launch Services database?