Text View Bindings?

I must be going mad here.

I created a tiny little app, it has one Text View in it. I did bind the “Attributed String” to the user defaults, but nothing gets written into the user defaults.

  • When I change the string in the .plist file manually, the content of the Text View does update. So it does read the information from the .plist correctly. It just doesn’t seem to write it.
  • I did tick “continuously updates value”, but it doesn’t seem to make a difference.
  • I dropped several other UI elements into the window, bound them to the User Defaults. All worked as expected. Including Text Fields. I do exactly the same for a Text View but it doesn’t work.

Is there something else besides ticking “continuously updates value” that you have to do to get Text Views to write their contents to the User Defaults?

OS X 10.5.5 XCode 3.1.1

After binding Attributed String, I saw messages like this in the Debugger Console:

Binding Data and using the NSUnarchiveFromData Value Transformer worked just fine though.

Thanks. Unfortunately, that didn’t work for me. But it did push me in the right direction.

I tried binding “Value” and using “NSUnarchiveFromData” and that worked just fine, provided you switch off “rich text” for the Text View. No idea why though. Bindings are still a very mystifying subject for a lowly AS dabbler like myself.