Tiger restricting Application Bundle for Managed Account?

I am trying to add an AppleScript application to the approved application list for a Managed account in OSX 10.4.
It is a simple script that activates another application in a hidden folder, and runs perfectly in the Managed account as long as I don’t restrict use of apps in the Parental Controls preferences.
I want to restrict use of some applications while allowing the use of the AppleScript application.
The AppleScript app does not show up in the list and when I use “locate” to add it I get an error message that states:
“App_Name does not work with the limitations you have selected.”
Has Tiger added restrictions for AppleScript use? This procedure worked perfectly in Jaguar.
Tiger refuses to allow me to add the app to the list.
Anyone run across this or know of a work around?

Model: iBook G4
AppleScript: 2.1.1
Browser: Safari 417.9.3
Operating System: Mac OS X (10.4)

I also get this with AppleScript apps (both plain and studio-based), but not with Obj-C apps; Not sure what to make of that.

Thanks Bruce.
I’m not getting any answers from Apple’s forum either.
I know nothing about Obj-C programming, but let me ask you this.
My script is nothing more than:
tell application “foo”
end tell
How can I do that in something Tiger will allow me to add to the approved app list in Parental Controls?
Thanks for responding.

I thought this might be the case. A quick test shows that AppleScript apps are not restriced by Parental Controls.

Note though, that if your app uses properties to retain values, then you’ll want to make sure others have write access to the app.

Did I misunderstand, or are you saying you were able to allow use in the Parental Controls?

My privileges are read and write for all.
The app will work in a Standard User (non administrator) account, allowing the User to open it or open at login.
But as soon as you apply Parental Controls (Managed account) and “User can only use these apps” it locks the User out of the AppleScript app without a means of adjusting its usability.
It doesn’t show up in the list of checkable (allow/disallow) applications.
With other applications you can use “locate” to add an application to the list, then check “allow”.
This is not working with the AppleScript app. When you click “add”, you get the “won’t work with these limitations” error.
This was quite simple in Jaguar.

Parental Controls does not (seem to) support denying them; So, you don’t even need to add them to the list.

Try it out yourself!

I am attempting to allow them, while at the same time restricting other applications. As soon as you apply controls and make the account “Managed”, Tiger denies the AppleScript apps, whether plain or bundled. The answer below was provided by “biovizier” on the Apple Discussion list.

"The problem you describe is related to the issues covered in these documents:

So basically, programmes selected by the “admin” have their ‘CFBundleIdentifier’ recorded in ‘mcx_settings’, but AppleScript apps aren’t given a ‘CFBundleIdentifier’ automatically so they can’t be selected. If the app is an “Applications Bundle”, this is fairly easy to work around - just control-click on the app’s icon, select “Show package contents” from the contextual menu, navigate through “Contents” to the “Info.plist” file, and open it in a text editor. The file is made up mostly of simple “key” / “value” pairs. Without interrupting an existing “key” / “value” pair, just insert a variation of these lines:
Choose something suitable in place of ‘com.mycompany.MyApp’, but keep in mind they must be unique. Save the changes, then duplicate the whole app. If all went well, it should be possible to choose the new copy of the app in the “Accounts” pref pane. Duplication isn’t strictly necessary, but it seems to be fairly reliable in getting “launch services” to recognize the change."

Thanks again Bruce for your effort.

When I tried it, AppleScript apps were not denied or restriced in anyway, despite them not being on the allowed list.

That explanation makes sense, thanks for sharing.

Technical Q&A QA1373: CFBundleIdentifier and user application access