Trouble getting started with AppleScriptObjC

Hi ,

I’m trying to learn AppleScriptObjC from the tutorial Craig posted. I think I understand most of the principles covered in the tutorial , however , it seems like there might be a problem with either Xcode or perhaps a setting in Xcode/Interface Builder.

When I type the properties with a value of “missing value”, like in the tutorial, they do not show in Interface builder. Control-click drag to connect the “setTextViewFromTextField_” class (blue cube) also doesn’t work. Yet somehow the button will connect to other objects like the Fonts class (Blue cube)

I’ve tried adding the properties, as Outlets, manually but alas that doesn’t seem to work either.

Anyone else come across this.

I’m using:

Xcode: 3.2.1 (1613)
Interface Builder: 3.2.1 (740)
Instruments: 2.0.1 (1096)
Dashcode: 3.0 (328)
Mac OS X:
10.4: (8S2167)
10.5: (9J61)
10.6: (10A432)

on OS 10.6.2

Any help greatly appreciated.

Many thanks


Model: Macbook Pro 2.5 Ghz 2 GB SDRAM
Browser: Safari 531.21.10
Operating System: Mac OS X (10.6)

Are you Control-Click Dragging from the App Delegate(Blue Cube) to the IB element you want referencing the variable or vise versa, because when connecting IB elements to variables with missing values in your delegate its usually * (Control-click drag) delegate to element* not (Control-click drag) element to delagate unless the variable will have data stored in it during runtime

another problem could be that you copy and pasted Craigs script and didn’t change the name in your app delagates script, it has to be the same as the name of your app.

Application name:MyFancyApp

script CraigsFancyApp

end script

will not work

Hi EricL,

Thanks for the ideas. I tried all the options you mentioned , as they are listed on the tutorial thread, before I posted here.

After trying various options I downloaded the source files Craig used and used it as a template. In the template it appears to show connections going both ways. Am I correct?

Also when I re-typed my own app using Craig’s script as example, the connections also didn’t work. In other words I made a brand new project and labelled everything EXACTLY as Craig did to try to troubleshoot. The Appdelegate shows up in IB but I can’t make any connections to or from it, since the Outlets and Actions don’t show in the App Delegate.

I then tried adding Outlets and Actions manually but it’s like there is a miscommunication between Xcode and IB. That’s why I think I have missed a setting somewhere.

I will keep at it and post my findings.

Thanks again.


Makes sure (a) that you’re saving in Xcode before switching to IB, and (b) that in IB’s Preferences → General you have checked When documents activate: Synchronize with Xcode.

Hi Shane,

That was in fact checked already. Thanks for the hint though, duly noted.

I will try from the beginning of the tutorial again and also make a brand new project. I will get this to work. It’s become an obsession now. :smiley:

Will post when I get it.

All the best and thanks again for trying.

I wouldn’t rule out that it’s a problem with Xcode or IB, but the fact that Craigs connections show up when downloaded makes me think that it might be something small thats getting overlooked. With that being said it’s hard to diagnose this problem without seeing exactly how you are connecting them because this aspect of Xcode and IB are so heavily interface based, do you think you could maybe provide step my step screen shots or possibly a screen recording of what you are trying to do?

I think there might be a problem with my Xcode. I have been reading an Objective C tutorial today and followed the IB instructions for it. Made connections in IB without problems. All the code works perfectly with connections and all !!!

What gives??? Maybe my ASOC stuff for Xcode is damaged somehow. Don’t even know if thats possible. (Especially since the downloaded project worked)

Perhaps this is natures way of telling me…Time to learn Objective C properly !! :lol: It’s been fun learning so far !!

I will try again in a few days, but Objective C hooked me I think.

Will post here with my next attempt. Will also try to include screenshots if it fails horribly.

Thanks again