Turning off finder duplicate sound effect in AS


Finally got back Home after being on the Dark Side for a number of years, can’t beleive I did not do it sooner.

I am now getting myself re-acquiented with Apple Script and I decided to write this pretty massive script. WOuld not have been able to do it with out MacScripter.

In this script I am copying a large number of files with the finders “duplicate” command. At the conclusion of each file copy the finder is making the user interface sound effect. Is there a way to turn it off the sound for these file copies that are being done in AS? I know I can turn it off in my preferences, but I like the sound effects when I am working directly in the finder myself.

Any help would be greatly appreciated.



I spent a decade on the dark side also, although I arrived there from the Commodore 64 and only 3 years ago found the true path.

Try this:

set volume alert volume 0

The alert volume can be set anywhere from 0 to 100 (see the dictionary under Standard Additions). I would recommend re-setting the alert volume to something around 80 or 90 after the script has run so that you will still hear it when in the Finder.

Changing the alert volume should not alter the system volume, so you can still play music without any beeping going on in the background.

Good luck,



Thanks a bunch. This will work perfectly.

I used to manage large Mac networks (in the 300-500 node range) back in the days of System 7, still at that time our back end was mostly Unix (both AIX and AU/X). Stayed with Unix and Linux but had to go to the dark side for workstations, but I am SOOOO glad to be back.

Take care,