URL Access Scripting hair-pulling.

I must admit, I struggle with every line of Applescript I write. And I’m a professional programmer. Geesh.
But, last night I stayed up way too late for one simple task. I am just trying to upload a file via ftp using the URL access scripting option.
What I really need is an interpreter for error codes -1700 and -1703. I guess I just don’t understand how I can have type problems when I reference a file. It seems plain as day simple.
I don’t have one of the exact attempts that I tried last night in front of me, so I’ll wing it here. But, it goes something like this.
Tell Application "URL Access Scripting "
upload “macintosh HD:sample text” to "[url=ftp://ftp.myserver.com/mydirectory/more&quot]ftp://ftp.myserver.com/mydirectory/more&quot[/url]; with progress
upload the file …
upload the alias…
I don’t seem to know when to use what. Or how to make a reference to the file that URL Access appears to like. I have all the Apple Applescript manuals. I have read, re-read about 40 times the method to make refereces to files. Why is it so difficult that a simple ‘path’ name doesn’t work? How about putting some intelligence into those error messages? Four hours of trying to do one command. And then, that’s on top of when I tried it out when it first came out. Over a period of a couple of days. Where can one go to PAY someone for simple answers to simple questions about Applescript?
Thanks for your help.

Well, here’s an update.
It works on my OS9 iMac DV SE. But that’s not the computer I need it to work on.
It does not work - the EXACT same script - on my 6100/G3/300 8.6 machine.
Go figure.

You could always try using an FTP application to to get the file. Both Anarchie & Fetch are scriptable (& I’m sure some of the other FTP apps are too).
There are some good scripts out there to use those apps (DropFTP for one).
hope this helps, Cameron

Here is a sample of a script that i use on a webserver that works great. The key is the slash on the end of my destination URL.

property myFTP : "ftp://username:password@" --you need the slash
set uploadFile to ("myHD:Folder1:filename.gif")
tell application "URL Access Scripting"
upload file uploadFile to myFTP replacing yes with progress without binhexing and authentication
end tell