/usr/bin/disable with Leopard

I have decided to install Leopard (10.5.4) on my G5.
Unfornutaly a script that was working on Tiger does not work in Leopard.
The script

set thePrinter to "HP"
tell application "Printer Setup Utility"
	set current printer to first printer whose name is thePrinter
end tell
do shell script "/usr/bin/disable " & thePrinter

get the following error:

sh: /usr/bin/disable: No such file or directory

Can anyone help me?


two reasons:

Printer Setup Utility doesn’t work the same way as in Tiger.
in Tiger /usr/bin/disable is actually an alias to /usr/sbin/accept. The alias doesn’t exist in Leopard

try this

set thePrinter to "HP"
do shell script "/usr/bin/lpoptions " & thePrinter & " ; /usr/sbin/accept " & thePrinter

Thank you Stephan.
I tried your script but it did not disable the printer. After some research I found the right command.

set thePrinter to "HP"
do shell script "/usr/sbin/cupsdisable " & thePrinter

It works. The printer pauses than get all the jobs.
I have to do that because my complete script send about 50 pages to the printer and my HP sends me “Out of memory error”. If I print 7 at a time I don’t have the error.

Thank you thank you thank you!!! I had a similar script at work - as I can only print during certain times of the day. My script broke too when I upgraded to Leopard.