W T F.. This photoshop script looked normal yesterday..

I’m really hoping I’m not over looking some n00b detail here, but two days ago I made this script. It looked normal and functioned normal. Today I go to work on it some more and it’s in a completly different syntax. Any one ever see this before or know what this has happened?

		tell application "Adobe Photoshop CS4"
			make new document with properties {«class Wdth»:2.5, «class Hght»:2.5}
			«event 8BIMScAl» «class pADc»
			«event 8BIMFill» selection of «class pADc» given «class FCnt»:¬
				{class:«class cRGv», «class pRRv»:100, «class pRGv»:100, «class pRBv»:100}
			«event 8BIMDslt» «class pADc»
		end tell

Thanks in advance to anyone that can help here.

Model: iMac
AppleScript: 2.0
Browser: Firefox 3.0.1
Operating System: Mac OS X (10.5)

OK, works now. The fix? Restart Script Editor. I thought about deleting the post all together, but I guess this could be beneficial to any one who has a similar issue. Odd part was, it was only with the part of the script the dealt with Photoshop CS 4… I would still be interested to see if any one knows the “why” behind this one.

Hmm… I have not seen this specific error, but every once in a while (more often than I’d like) I run across situations where a script wont work, and a restart of Script Editor fixes things. Irritating!

Those are raw Apple Events, and they become visible when a script somehow loses the connection to its dictionary. You can typically see them when you’ve coded with terms for one version of an app but open into another.

Makes sense, thanks for the explanation