what is POSIX?

I think this may be the right place to ask this question
What is POSIX path?
This the second time when I tried to run the script with POSIX path it gives me error.
is there any enable or disable button for POSIX ? I don’t know

I have two script, which is given by some goods guys from this forum and according to them it works well on their machine with OS 10.2.6 but not on mine.

Script one

set i to "myPassword" 
 set AppleScript's text item delimiters to ":" 
 set appToLaunch to "" & (items 1 thru -2 of (path to me as text)'s text items) & ":InstallDG" 
 set AppleScript's text item delimiters to {""} 
 do shell script "sudo /System/Library/Frameworks/Carbon.framework/Versions/Current/Support/LaunchCFMApp " & quoted form of POSIX path of appToLaunch password i with administrator privileges


Script two

tell application "System Events" to make login item at end with properties {path:(POSIX path of "path:to:application"), hidden:false}


have any idea
please reply I am stuck.

These errors are not related to POSIX path. The first one is due most probably to a problem with “LaunchCFMApp”, which is unable to launch “InstallDG”.
The solution for the second one is very simple:

set x to POSIX path of "path:to:application"
tell application "System Events" to make login item at end with properties {path:x, hidden:false}

A POSIX path is a simple file specification type-unix.
Simple path: “path:to:item”
File specification: file “path:to:item”
Alias: alias “path:to:item”
POSIX path: “/to/item”
You use it specially when using “do shell script”, which targets the shell and works with posix-path as file reference. Some times you must use it in conjunction with “quoted form”, which avoids conflicts with files/folders containing blank spaces or special characters in its names.

thanks jj
the problem with the second script is solved but what about the first script.
Can you please tell me what could be the problem with “LaunchCFMApp”,

Sorry, no idea…
I’ve found this error some times but never tried to find an explanation… Maybe you can take a look to Apple’s OSX-UNIX forum…