Working scripts do not work anymore when recompiled. Why?

Hi All,

I am not sure what’s going on here.

I have a few working scripts that were compiled earlier but work now only if I do not recompile them. If I recompile them even without changing any codes, the compiled scripts would not work.

Sorry, I can’t remember if the version of AppleScript and/or Script Editor are the same before as with my current ones but it wasn’t too long ago that I compiled my scripts.

The current versions of the Script Editor and AppleScript that I have are as follows:

Script Editor Version 2.1.1 (81)
Applescript 1.10.7

Would appreciate any input so I could try to edit my scripts further. Else, I am stuck.


archseed :frowning:

That’s very light on information. Have you changed operating systems? What, specifically, is it that fails to compile? Is there an error message? Tell us much more about the failure. Have you moved or renamed a file referred to by an alias in the script?


OK, sorry for the dearth of information on my earlier post.

Short of posting a lot of codes, here are answers to your questions:

Have you changed operating systems? Yes I have, twice since I compiled the scripts that I mentioned.

What, specifically, is it that fails to compile? Actually, there is no problem in compilation. The scripts compile but it does not work the way it used to work before. The scripts that I have tested would work up to a certain point and then quit. There is not even an error message so this give me fits.

Is there an error message? Nada and that’s the problem. See also immediately above.

Have you moved or renamed a file referred to by an alias in the script? Nope. As I said, when I recompiled the scripts with very little editing (not even altering the codes), the script would recompile successfully but then the resulting compiled script fails to work.

Could it be the operating system update? But then, why would the old compiled script work in the new system?

I am not sure about this but I suspect it’s the Script Editor that’s causing the problem. What do you think?

archseed :frowning:

Have you tried trashing the pref’s only last week my Script Editor was throwing up a register Script Debugger window every time I pressed run. I had tryed the demo a quick zap resolved the issue.


I will try that one and let you know.

archseed :slight_smile:

Hi Mark,

Here’s very quick update.

I trashed my pref file for Script Editor and another plug-in that piggy-backs on it. I still got the same result - original script works but recompiled with the “clean” Script Editor breaks it.

My Script Editor might be have some bugs or broken? I may try other things but if there are other suggestions worth trying out there, I would greatly appreciate help.


archseed :frowning:

Hi All,

Forgive me folks! I should not have gone around bashing Script Editor. I should have bashed my head instead. Blimey!

I has my script saved before as “stay open” and when I tried to recompile, I forgot to save it as stay open. So, that was the main problem. Sorry.

FWIW, for those who might run into the same problem, check to make sure that you are saving your script as “stay open” if it was originally a stay open script.

Many thanks for those who tried to unravel my false mystery.

archseed :smiley: