Xcode is quitting unexpectedly... :/

I had a break from Xcode a few months ago, now when I try to open Xcode the icon appears in my dock then disappears almost instantaneously. I then get this message:

The application Xcode quit unexpectedly

Mac OS X and other applications are not affected… etc.

Does anyone have any advice on what I should do?

Thanks in advance!

Model: MacBook
Browser: Firefox
Operating System: Mac OS X (10.5)

Sendura …

See: http://bbs.macscripter.net/viewtopic.php?id=26718

… and I now have a brand new iMacG5 and the same awful behavior.

I sure would like others to chime in on this problem … it’s crunch time.

John Love

Have you tried reinstalling XCode from your OS disc (or downloading the current version’s disc image from the Apple site if it’s different)? I had weird crashing problems a while back with XCode 2.5 and a reinstall of the developers tools fixed it.

If you haven’t done that yet, it would be a relatively easy step to try.

Model: PowerPC G5 Tower OS 10.4.9
AppleScript: XCode 2.5
Browser: Safari 419.3
Operating System: Mac OS X (10.4)

I did try reinstalling it- didn’t work.

HOWEVER my computer (quite a while back now) went crazy and corrupted it’s hard drive, luckily I had a backup from a few hours before. After getting a new hard drive and reinstalling everything (including Xcode) it seems to work now. Wierd. Though the fact that it’s a new hard drive might be a good reason :smiley:

Anyway, thanks for your help!

Model: Black MacBook
Browser: Firefox 3.0.1
Operating System: Mac OS X (10.5)

My iMac G5 is brand-new (4 gig DRAM and 500 gig HD), so the hard drive is not the problem.

I did re-install XCode 3.0 from my Leopard CD and the AppleScript Studio problems went away … however, my Cocoa apps did not behave correctly when re-built (I suspect because the hidden libraries are different).

I then applied the 3.1 update … I re-built my Cocoa apps and their behavior became correct … but my AppleScript Studio problems (editor problems and crashing) definitely re-appeared.

Matt Boy - I see you are using Tiger and
Sendura - you are using Leopard, but I don’t know if it’s an Intel box
Me - Leopard and an Intel box

Could these dissimilarities be the real source of the problem?

I just this second was trying to recall if I was using 3.1 with my previous non-Intel box (had Leopard) … and the answer is that I did use 3.1 and Studio crashed alot … so PPC versus Intel apparently is not the difference.

My gut says XCode 3.1, in particular the Editor, is the problem … once again I do hope others chime in.

Thanks in advance.

John Love

Please check out this link that I just this second found:


… and I just confirmed what this link stipulates … nothing to do with length:

end script

on – crash after the space following “on”

John Love