XML in AS 1.7 <>AS1.9.1


Being all excited about the xml related capabilities of applescript and filemaker, i set out to study a bit on the subject.
So i set up a simple filemakerdb with some names and birthdays, enabled the webcompanion and opened the url with
This works perfectly well in Safari, although its ugly, it is correct xml.
So I moved on and tried to get the same resultlist with some code I lurked from the soapXMLRPC-documentation from apple and made

set resultlist to mycall()

on mycall()
	tell application "my.ip.address/fmpro?-db=birthdays&-lay=table&-format=-dso_xml&ishappy=1&-find"
		return call xmlrpc {method name:"", parameters:""}
	end tell
end mycall

log resultlist

no can do, i invariably get error -916, whatever i try for alternatives to the app name, the method name or the parameters.
the method name seems to be mandatory, but to what should that correspond in the webcompanion-concept?

or am I trying to set up something impossible?


I have absolutely no experience with what you are attempting to do but maybe it would be helpful to look at osaxen.com’s XML-RPC implementation to try to get an idea of what is required.


tell application "http://osaxen.com/xmlrpc.php"
	call xmlrpc {method name:"osaxen.findPackage", parameters:"mail"}
		--> http://osaxen.com/xmlrpc.php got an error: An error of type -916 has occurred.

as you can see, i tried the examples (well, several, one never knows) verbatim.
but those are AppleScript 1.7 syntax,
While i am on AS 1.9.1, I fear something has dramatically changed in the AS-XML implementation.

I just ran this in OS X 10.2.3 with AS 1.9.1 and it worked fine. I won’t paste the result here because it’s rather lengthy.

tell application "http://osaxen.com/xmlrpc.php"
	set x to call xmlrpc {method name:"osaxen.findPackage", parameters:"mail"}
end tell

Now I’m freaking,
I copy-pasted your code, checked the version (10.2.3) and ran it :

http://osaxen.com/xmlrpc.php got an error: An error of type -916 has occurred

:x Aaargh! what’s wrong?
Apparently, we are both using the exact same systemversion, AppleScriptversion. So what else could be wrong?
:idea: gonna reboot and get some coffee…

I’m not sure unless it’s a connection problem. I just ran it five times, using Script Debugger, Script Editor 1.9 and Script Editor 2.0, and it worked every time.

This looks like a private chat…
I am using Script Editor 1.9, so that one cannot be the problem.
let’s assume it is a connection problem : i am behind a NAT-firewall, which in turn is behind my ISP’s proxy. I know this can cause troubles, but we are doing standard HTTP here :!: I do have access to osaxen.com/xmlrpc.php; I have the page right in front of me.
I thought of a test in FileMaker : try to import data from an XML source, but i can only specify the URL for the data and optionally an XSLsheet, how does that map to the different methods?
All this XML doubletalk is pretty frustrating.

I’m not sure how all of this translates to FMP. :?

Maybe you’ve already explored this page but if you haven’t, it might be useful. There are various references that might be helpful.