saving a self-contained movie in quicktime [7.2]

I recently upgraded to quicktime version 7.2, the latest update made available recently by Apple. Since upgrading I’m having problems with some applescript code that worked in previous quicktime 7 versions. I can no longer save a movie in quicktime. Are you having the same problems or do you know of any applescript code that will work? Here’s my non-working code. Note: you need a movie open in quicktime and this code should save the movie to a new movie file on your desktop with then name “”.

set A to path to desktop as string
set new_file to A & ""

tell application "QuickTime Player"
	tell document 1
		save self contained in file new_file
	end tell
end tell

Note that changing to this code doesn’t work either… save in file new_file


Down loaded your script worked sweet in 7.1.6, just upgraded to 7.2 same result as you “QuickTime Player got an error: NSInternalScriptError”

Thanks for verifying that it was the update that caused my problem Budgie. Now we need a solution though! Anybody???

looks like theirs a few issues with the 7.2 update, seems like going back to 7.1.6 is the only work around for now.

Hi Budgie. I did have some other problems too after updating to 7.2, but a reinstall of perian and flip4mac solved those issues. It’s not critical right now so I’ll wait and see if another update comes along soon because as you pointed out a lot of people are having problems. But I’m glad to get those instructions on how to go back to 7.1.6 if needed, thanks.

exactly the same problem here with the same set of commands in AppleScript. Trying to “save self contained” gives me the NSInternalScriptError.

I still have a Mac mini with 10.4.9 and QT 7.1.x around, so in the meantime I’ll use that one, hoping that QT 7.2.1 will come soon

My machine: MacBook 2.16 GHz, 2 GB RAM, 10.4.10, QT 7.2