Transmit Upload not working

Hi all,

I am trying to upload my site but I Transmit keeps given me an error: “NSCannotCreateScriptCommandError”.I think my code si correct.

tell application “Transmit”
tell document 1
if (connect to “” as user “•••••” with password “••••”) then
if (set their stuff to “/website/html/deals/pages”) then
if (set your stuff to “/Uploaddir/WebSites/html/deals/pages”) then
if (upload “/Uploaddir/WebSites/html/deals/pages”) then
end if
end if
end if
end if
end tell
end tell

Im not sure what is wrong. Thanks for the help

What happens if you change this line:

if (upload "/Uploaddir/WebSites/html/deals/pages")


if (upload item "/Uploaddir/WebSites/html/deals/pages")

If I change the file to “upload item” I get this error: NSCannotCreateScriptCommandError. I know I can use code from the example but im not sure why it works.


In this line:

if (upload "/Uploaddir/WebSites/html/deals/pages") then

Is “pages” a folder/directory? If so, does it work if you change the line to:

if (upload item "/Uploaddir/WebSites/html/deals/pages/") then

I got the upload to work I put this in my code: (Begin synchronizing modified local files with remote files)synchronize direction upload files method update. That seemed to fix it. Now I am having troubles closing the synchronize complete window. I have tried using: [window = closeable]. Is there a better way to do is?


I tried to work around the same issue once and was not successful. I’ve asked Panic to address the issue. In the meantime, you could probably use a utility such as Extra Suites to activate the default button.

tell application "Extra Suites" to type key "enter"